With the new word manipulation from 1.4, I think it's about time that we separated costume and costume number.
Costume is the name of the sprite's animation frame. <switch to costume[ <{ idle }>
Would make the animation frame automatically change to the frame called "idle", whatever number that is.
Costume# is the number of the animation frame in the list of costumes (animation frames) shown in the costume tab.
Normally, this is simple and there won't be problems.
But what if there was a sprite with a costume called "1" which is the second costume, and "2", which is the first costume?
Would:
<set{ generic variable }to( 1
<switch to costume[ <{ generic variable }>
Make the sprite switch to the costume called "1" or the costume called "2"?
Offline
The solution is to not call a costume "1".
Offline
That was a very simple example. There are some times when it can be complicated.
Offline
No, if you use a variable like that, it will only do the frame number.
Though i would like it to look for the name though. if thats possible, maybe add in extra thing in the sensors like you have costume# maybe costume-name?
Offline
Keani wrote:
This would be somewhat helpful
Kind of.
Offline