I have a project where I have to constantly check for a collision between sprite 1 and 55 other sprites. The code would be MUCH simpler and shorter if instead of 55 IF blocks to check for each sprite, I could have just one if block and repeat it while incrementing through the sprites in order. Adding "Next Sprite" and "Sprite #" blocks would allow for this. Think of it as what "Next Costume" and "Costume #" do on a local level for a single sprite, "Next Sprite" and "Sprite #" would do on a global level.
Offline
I see what you mean - it would be a whole lot easier to just put in a few blocks instead of 55. Unfortunately, I feel this may take away from the simplicity of the program, which is what the program is all about.
Offline
Actually, you can already shorten your script quite a bit by making a list with all of the sprites you want the sprite to collide with, then using these blocks for the collision script:
<touching (item (any) of [collistionList])>
It should work perfectly, and reduce the need for huge numbers of <touching ...> blocks
Offline